Missing Mediaid.bin file

Recently I got asked to backup a Vista machine. I’m not a big Vista fan, so this was the first time.

I went ahead and backed up the entire machine onto my external USB hard drive, no problems.

However when it came to restore to a new vista machine I found myself with the following error:

The restore did not finish successfully. Error code:
The backup file could not be found. Check your hardware configuration or restore from a different backup (0x8100001A).

Through the wonders of the internet I discovered the Microsoft Knowledgebase article appropreately titled “Error message when you use the Restore Files option to restore a backup file on a Windows Vista-based computer: “The restore did not finish successfully. Error code: 0x8100001A”“.

As it turns out I must have deleted the “what seems to be unimportant file” Mediaid.bin which the backup utility places in the root of the backup drive, with no reason or explanation.

I soon learned the importance of this file as usefully (sarcasm) the article says:

If the backup location is inaccessible, or if the Mediaid.bin file is corrupted, contact Microsoft Customer Support Services (CSS) for help rebuilding the Mediaid.bin file.

Great, I’m really not going to be calling them, there must be another way…

Fortunately there was, and so to rebuild the “Mediaid.bin” file these are the steps to take:

  1. Download and unzip “sdutil.zip” and rename the containing “sdutil.ex_” to “sdutil.exe”.
  2. MOVE “sdutil.exe” to your backup drive. (eg: G:\)
  3. Right click on “sdutil.exe” and click “Properties”, click on the “Compatibility” tab at the top, and tick “Run as administrator”, follow the instructions. (If you don’t do this you’ll see “Access is denied. (0×80070005)“)
  4. Find the “Catalogs” directory and COPY the “GlobalCatalog.wbcat” to your backup drive (eg: G:\)
  5. Go to Start > “Start Search” and enter: cmd, click on the “cmd” program from the list.
  6. In the black command prompt window enter your backup drive (eg: G:), press enter, and the prompt will change to “G:\>”
  7. Now in that same window type: sdutil mediaid GlobalCatalog.wbcat [backup drive (eg: G:\)]and press enter.

A Mediaid.bin file should now appear on the backup drive and you should be able to continue with your restore as normal.

Note: “sdutil.exe” only runs on Windows Vista, it will not run on Windows XP.

source.

About admin

Website Administrator
This entry was posted in Sysadmin. Bookmark the permalink.

15 Responses to Missing Mediaid.bin file

  1. Christian says:

    Hello,

    this is a good post, but, I am having a problem in CMD. It is giving me an Error: The system cannot find the path specified. (0×80070003)

    Any idea why ?

    Thank you

  2. nur says:

    you know what, i have been trying to recreate this mediaid.bin file all yesterday and today.. and either i get a access denied.. then i got unrecognised command, then i got insufficient number of parameters.. im about to lose my mind.. if anyone knows the answer please let me know.. thank you :)

  3. Lin says:

    the most helpful answer yet. And I have done quite a bit of searching for a solution to this problem. Unfortunately when I get to the very last step listed (#7) and hit enter I get a message that says: “sdutil is not recognized as an internal or external command, operable program or batch file” and i do not get the mediaid. bin file
    Any suggestions why this is coming up this way? Any help is appreciated.

    Thanks

  4. Mike Akridge says:

    This is a great post but I have a bigger problem. I used my HP HomeServer to backup my Vista 32 system and have now upgraded to Vista 64 to run 8 GM RAM so I don’t know the the location on the server. I assume it is at my \servername\ on my network and not sure if the same solution will work. Unfortunatly “ALL” my company files are on there and I need to get them ASAP. Any solutions? PLease I need the help.

  5. Bill says:

    Once I followed your instructions “exactly”, it worked perfectly. BTW the backup was originally created on an XP machine, than at some time copied to a vista machine and by the time I needed to restore a file I was on WIndows 7. If you follow the instructions it works perfectly. Thanks a bunch!

  6. Aaron says:

    Thank you, thank you! I had the same problem, search Google and Microsoft and couldn’t come up with anything that would work, and was not about to call MS tech support. Bill’s comment (above) was the key – follow the steps EXACTLY. On Windows 7, right click on command prompt and run as an Administrator. Also, Windows file explorer may not let you search the backup directory, but if you use something like xplorer2, its a breeze. Once I figured out the above, the fix took two minutes and saved 500GB worth of backup. You are a lifesaver.

  7. Mak Tal Oz says:

    This walk-through for recreating the mediaid.bin file is spot on! :) However, for those of us that sometimes tend to take things a bit to literally, I’d just like to clarify step #7 a bit to alleviate any potential confusion:

    After accessing the correct drive letter for your backup, “e:\” in my case, the EXACT command I typed to recreate the mediaid.bin file was as follows,

    sdutil mediaid GlobalCatalog.wbcat e:\

    The only difference that should exist in the above command is the letter of the drive where your backup resides.

    Again, this walk-through is very helpful, I just didn’t want anyone else to waste time making the same mistake I did (trying to run the command as “sdutil mediaid GlobalCatalog.wbcat [backup drive e:\]“). :P

  8. Pingback: Problemas al restaurar copia de seguridad Windows 7, error MediaID.bin. Restaurar archivo MediaID.bin « Bichotll's Blog

  9. Chema Sanz says:

    Well, thanks for this post. In fact I get the Mediaid file with your indications, but once the Restore utility is started it still says it does not find a valid backup/restore file set. And everyting is there: the catalog, the zip files, etc.

    Any clue of what might be happening?

    Thanks

  10. Michele says:

    Where is your backup set located on e: the root or within a subfolder on e: ?

  11. CGC says:

    In step 3, there wasn’t any instructions to follow. And in step 4, where to find the “catalogs” directory?

  12. Craig Quik says:

    Better than Microsoft’s support pages (not hard). Thanks a lot!

  13. Art says:

    Fantastic! Worked perfectly. Also, thanks for the link to download sdutil.zip.
    I wasn’t clear on where to get that file from. Microsoft website? But because you provided the link, it took care of that part of it.

  14. Arch says:

    sdutil seemed to work for me when I followed the instructions. I found that after running it I had to have the backup on an external drive (not the internal D: that I really did the backup to) and the restore happened from there. The restore operation skipped numerous files in both “/program files…” and the active user’s registry file and numerous other files, as if restore doesn’t run with admin privileges.

    So the easy fix going forward is to always copy out the mediaid.bin file with the backup. I just have to keep them paired with the correct backup file set, I assume.

    Thanks much.

  15. Naomi says:

    So from what I’ve worked out, the guide says to get to the catalogs folder hich is found inside of your backup. You can open it to find the folder. I am on the otherhand get in the error that says the filename, directory name or volume label syntax is incorrect. 0x8007007B

    Any advice?

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>